PHP 4.0 Bug #7386 Updated: referenced symbol not found when starting Apache

From: Date: Sun, 22 Oct 2000 18:18:11 +0000
Subject: PHP 4.0 Bug #7386 Updated: referenced symbol not found when starting Apache
Groups: php.dev 
Request: Send a blank email to php-dev+get-35802@lists.php.net to get a copy of this message
ID: 7386 Updated by: sniper Reported By: andres.fernandez@central.sun.com Status: Feedback Bug Type: *Install and Config Assigned To: Comments: Is this really correct? The error says: 'Cannot load /usr/local/dsoapache/libexec/libphp3.so' ??? And you are trying to install php4.0.3pl1??? --Jani Previous Comments: --------------------------------------------------------------------------- [2000-10-21 22:38:45] andres.fernandez@central.sun.com There seems to be other people with the same problem although I have the latest version of Solaris installed on my pc at school. Both Apache 1.3.14 and php 4.0.3pl1 compile under the os but when I try to run Apache it can't find the proper symbols. Does solaris store these in an alternate location. I compiled with gcc 2.95.2 and gnu make..... These are some ld library locations: ./usr/lib/ld.so.1 ./usr/lib/librtld.so.1 ./usr/lib/libld.so.2 ./usr/lib/libld.so.3 ./usr/lib/mdb/kvm/krtld.so ./usr/share/man/sman1/ld.so.1.1 ./usr/ccs/lib/libld.so.2 ./etc/lib/ld.so.1 The console output is below. Syntax error on line 224 of /usr/local/dsoapache/conf/httpd.conf: Cannot load /usr/local/dsoapache/libexec/libphp3.so into server: ld.so.1: /usr/local/dsoapache/bin/httpd: fatal: relocation error: file /usr/local/dsoapache/libexec/libphp3.so: symbol mysql_free_result: referenced symbol not found ./apachectl start: httpd could not be started --Any suggestions? Andrew Fernandez --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7386

« previous php.dev (#35802) next »