PHP 4.0 Bug #7524 Updated: Cannot start apache (undefined symbol: zend_ini_close_file)
| From: | torben@php.net | Date: | Tue, 31 Oct 2000 22:29:04 +0000 |
| Subject: | PHP 4.0 Bug #7524 Updated: Cannot start apache (undefined symbol: zend_ini_close_file) | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-36560@lists.php.net to get a copy of this message | ||
ID: 7524
Updated by: torben
Reported By: torben@php.net
Status: Closed
Bug Type: *Install and Config
Assigned To:
Comments:
Appears fixed in CVS.
Previous Comments:
---------------------------------------------------------------------------
[2000-10-29 20:01:03] torben@php.net
I've just wiped php4, Zend, and TSRM and checked out fresh versions
from CVS. Configuration script:
./configure
--with-apxs=/usr/local/apache/bin/apxs
--with-java
--with-mysql=/usr
--with-gd
--with-xml
--with-zlib
--with-curl
--with-sablot
--with-ibm-db2
--with-iodbc=/usr/local
--enable-wddx
--enable-versioning
--enable-sysvshm
--enable-sysvsem
--enable-sockets
--enable-shmop
--disable-debug
configure and make proceed as normal, as does make install. Then,
upon running 'apachectl start'. I get this:
/home/torben/work/php4
shanna% apachectl start
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so:
undefined symbol: zend_ini_close_file
/usr/sbin/apachectl start: httpd could not be started
Line 209 of httpd.conf is:
LoadModule php4_module libexec/libphp4.so
Nothing else has changed.
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=7524