PHP 4.0 Bug #7016 Updated: Error when starting iPlanet

From: Date: Sat, 04 Nov 2000 02:01:15 +0000
Subject: PHP 4.0 Bug #7016 Updated: Error when starting iPlanet
Groups: php.dev 
Request: Send a blank email to php-dev+get-37095@lists.php.net to get a copy of this message
ID: 7016 Updated by: sniper Reported By: lester@i-quest.com Status: Open Bug Type: Other web server Assigned To: Comments: reclassified Previous Comments: --------------------------------------------------------------------------- [2000-10-04 12:41:54] lester@i-quest.com This is the error I got when restarting iPlanet via command line after installing PHP4 w/o any errors showing up: conf_init: Error running init function load-modules: dlopen of /usr/netscape/server/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: relocation error: file /usr/netscape/server/bin/libphp4.so: symbol __pure_virtual: referenced symbol not found) Can you give me an ideas on what's going on here? Thanks. ======================================================================== We're using the GCC2.95.2 also. After configure, make and make install, these are the steps I did: 1. add the ff line in mime.types type=magnus-internal/x-httpd-php exts=php 2. edit obj.conf # note place following two lines after mime types init! Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/usr/netscape/server/bin/libphp4.so" Init fn=php4_init errorString="Failed to initialize PHP!" <Object name="default"> . . . # NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines Service fn="php4_execute" type="magnus-internal/x-httpd-php" . . </Object> <Object name="x-httpd-php"> ObjectType fn="force-type" type="magnus-internal/x-httpd-php" Service fn=php4_execute </Object> Are these correct? Thanks, Lester --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7016

« previous php.dev (#37095) next »