PHP 4.0 Bug #7636: php4+Apache+oracle+gd+freetype

From: Date: Sat, 04 Nov 2000 05:59:56 +0000
Subject: PHP 4.0 Bug #7636: php4+Apache+oracle+gd+freetype
Groups: php.dev 
Request: Send a blank email to php-dev+get-37109@lists.php.net to get a copy of this message
From: yangyh@mail.darharnq.com.tw Operating system: SunOS 5.7 sun4m sparc SUNW,SPARCstation-20,Solaris 7 PHP version: 4.0.3pl1 PHP Bug Type: Apache related Bug description: php4+Apache+oracle+gd+freetype I'm trying to install php4+apache1.3.14+gd1.8+oracle8 on my Sun Solaris machine and I am getting the following error when I try to start Apache: "Syntax error on line 238 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol png_set_PLTE: referenced symbol not found ../bin/apachectl start: httpd could not be started" Here is what I typed to configure PHP: ./configure --with-oracle=/u01/app/oracle/product/8.1.5 --with-oci8=/u01/app/oracle/product/8.1.5 --with-apache=../apache_1.3.14 --with-zlib=/usr/local --with-gd=/usr/local --with-ttf --enable-track-vars --enable-libgcc What am I doing wrong? Any suggestions on how to fix this? Thanks! -- Edit Bug report at: http://bugs.php.net/?id=7636&edit=1

« previous php.dev (#37109) next »