PHP 4.0 Bug #7641: cgi binary with "enable-discard-path" fails with empty doc_root value

From: Date: Sun, 05 Nov 2000 01:26:34 +0000
Subject: PHP 4.0 Bug #7641: cgi binary with "enable-discard-path" fails with empty doc_root value
Groups: php.dev 
Request: Send a blank email to php-dev+get-37149@lists.php.net to get a copy of this message
From: ugb-listen@gmx.de Operating system: Linux 2.2.16 i686 PHP version: 4.0 Latest CVS (04/11/2000) PHP Bug Type: Scripting Engine problem Bug description: cgi binary with "enable-discard-path" fails with empty doc_root value Similar Problems have been described in Bug id #5163 and Bug id #6201, but obviously are still not resolved completely : when compiling the cgi version, even a simple phpinfo() doesn't work when called via Apache (while it works fine on the command line). The error message in the browser shows up as: Parse error: parse error in /usr/local/apache/cgi-bin/php on line NNN (Apache 1.3.14 - other errors were reported by users of Netscape/iPlanet) I have tried lots of different compilation settings, and found only one common element: the problem only occurs if --enable-discard-path is specified. Any other combination of configure flags result in a binary that works fine as long as --enable-discard-path is not used. I tried both the download version 4.03pl1 and snapshot-200011041645, the only difference with the snapshot version is that it shows a different error message: Warning: Unexpected character in input: ' in /usr/local/apache/cgi-bin/php on line 116 Warning: Unexpected character in input: ' in /usr/local/apache/cgi-bin/php on line 116 Warning: Unexpected character in input: '' (ASCII=11) state=1 in /usr/local/apache/cgi-bin/php on line 116 Warning: Unexpected character in input: '' (ASCII=8) state=1 in /usr/local/apache/cgi-bin/php on line 116 Parse error: parse error in /usr/local/apache/cgi-bin/php on line 116 A temporary solution is to set the doc_root in php.ini to a non-empty value. However, under some circumstances it is undesirable to explicitly set this value - e.g. when sharing a single php binary among different virtual servers, so php shouldn't fail even without doc_root set. -- Edit Bug report at: http://bugs.php.net/?id=7641&edit=1

« previous php.dev (#37149) next »