PHP 4.0 Bug #7781 Updated: Unable to connect to ODBC Datasource
| From: | kara@php.net | Date: | Mon, 13 Nov 2000 15:19:14 +0000 |
| Subject: | PHP 4.0 Bug #7781 Updated: Unable to connect to ODBC Datasource | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-37932@lists.php.net to get a copy of this message | ||
ID: 7781
Updated by: kara
Reported By: ties@dse.nl
Status: Feedback
Bug Type: ODBC related
Assigned To:
Comments:
Does the user your webserver runs as (usually nobody) has read access to the odbc.ini file?
Maybe you have to set the environment variable ODBCINI pointing to the odbc.ini file location.
Previous Comments:
---------------------------------------------------------------------------
[2000-11-13 09:05:11] ties@dse.nl
This error i get when connecting to a unixODBC datasource:
Warning: SQL error: [unixODBC][Driver Manager]Data source name not found, and no default driver
specified, SQL state IM002 in SQLConnect in
/var/www/html/test.php4 on line 8
unixODBC 1.8.12 is correctly setup, I can access my Postgres database via the supplied
'DataManager' application. But somehow there seems to be no connection possible between
PHP and the ODBC Driver manager. These are the compile options I used for PHP:
./configure --with-apxs=/usr/sbin/apxs --target=i386-redhat-linux --prefix=/usr
--with-config-file-path=/etc --disable-debug --enable-pic --enable-inline-optimization
--disable-static --with-exec-dir=/usr/bin --with-regex=system --with-gettext --with-gd
--enable-debugger --with-jpeg-dir=/usr --with-png --with-zlib --with-gdbm --enable-safe-mode
--enable-sysvsem --enable-sysvshm --enable-track-vars --without-mysql --with-unixODBC=/usr/local
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=7781