PHP 4.0 Bug #7790: can't start apache after compiling with --with-mcrypt

From: Date: Mon, 13 Nov 2000 19:28:17 +0000
Subject: PHP 4.0 Bug #7790: can't start apache after compiling with --with-mcrypt
Groups: php.dev 
Request: Send a blank email to php-dev+get-37966@lists.php.net to get a copy of this message
From: brainy79@yahoo.com Operating system: Digital UNIX 4.0e PHP version: 4.0.3pl1 PHP Bug Type: Dynamic loading Bug description: can't start apache after compiling with --with-mcrypt Libmcrypt 2.4.6 (configured with --prefix=/usr/local/libmcrypt --disable-posix-threads) compiled and installed with no problem. PHP is configured with ./configure --quiet --with-apxs=/usr/local/apache/bin/apxs \ --with-imap=/usr/local/src/imap/imap-4.7c \ --with-mcrypt=/usr/local/libmcrypt PHP compiles and installs with no errors. Upon starting apache (1.3.14+the latest mod_ssl), I get the following error: Syntax error on line 210 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: Unresolved symbol in /usr/local/lib/libmcrypt.so: lt_dlopen /usr/local/apache/bin/apachectl startssl: httpd could not be started Exit 3 Any ideas? -Eric -- Edit Bug report at: http://bugs.php.net/?id=7790&edit=1

« previous php.dev (#37966) next »