Re: A rose by any other name?
| From: | Ron Chmara | Date: | Mon, 20 Nov 2000 22:03:35 +0000 |
| Subject: | Re: A rose by any other name? | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-38710@lists.php.net to get a copy of this message | ||
Sterling Hughes wrote:
>
> I'm currently grappling over the name for the (temporarily named)
> call_user_func_with_array() function which allows you to call a function
> with an array rather than the normal argument format (therefore truly
> calling a function with a variable number of arguments). Any suggestions
> (the attached patch is a working version of the function, it might be a
> little messed up because I deleted some different elements which I haven't
> committed yet.)
Yeah, the name is a bit awk word. (er...)
Taking a look at other user-function name, I'd make the folling suggestions:
1. Rename yours to call_user_func_array
2. Rename both to:
user_func
user_func_array
and deprecate the old name(s).
3. call_user_func_as_array
-Ronabop
--
Brought to you from boop!, the dual boot Linux/Win95 Compaq Presario 1625
laptop, currently running RedHat 6.1. Your bopping may vary.