PHP 4.0 Bug #7898: Apache 2 alpha 8 and current CVS problems
| From: | gamr at gattcomp dot com dot au | Date: | Tue, 21 Nov 2000 07:49:07 +0000 |
| Subject: | PHP 4.0 Bug #7898: Apache 2 alpha 8 and current CVS problems | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-38752@lists.php.net to get a copy of this message | ||
From: gamr@gattcomp.com.au
Operating system: FreeBSD 4.0
PHP version: 4.0 Latest CVS (21/11/2000)
PHP Bug Type: Apache related
Bug description: Apache 2 alpha 8 and current CVS problems
Configured php with
./configure '--enable-bcmath' '--enable-calendar' '--enable-dbase'
'--enable-filepro' '--enable-ftp' '--with-imap=/usr/local/'
'--with-mcrypt=/usr/local/' '--with-mysql=/usr/local/'
'--with-mm=/usr/local/' '--enable-inline-optimization'
'--enable-memory-limit' '--enable-dba=shared' '--with-gdbm'
'--with-snmp=/usr/local/' '--enable-ucd-snmp-hack' '--disable-debug'
'--enable-sysvsem' '--enable-sysvshm' '--with-zlib'
'--enable-versioning' '--with-ldap=/usr/local/' '--with-gettext'
'--with-mhash' --with-apxs2=/usr/local/apache2/bin/apxs
Configured apache 2 with
./configure --with-mpm=prefork --enable-cache --enable-disk-cache --enable-vhost-alias
--enable-status --enable-speling --enable-suexec --enable-so --enable-shared=max
--prefix=/usr/local/apache2
Getting the following error when trying to start apache 2
root@server /usr/local/apache2/bin > ./httpd
Syntax error on line 185 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/libexec/libphp4.so into server:
/usr/local/apache2/libexec/libphp4.so: Undefined symbol "__pure_virtual"
I have Apache 1.3.12 on this server also compiled in the same way from the same cvs and it is
working perfectly.
--
Edit Bug report at: http://bugs.php.net/?id=7898&edit=1