PHP 4.0 Bug #8016 Updated: gdbm functions no longer work

From: Date: Tue, 28 Nov 2000 22:40:00 +0000
Subject: PHP 4.0 Bug #8016 Updated: gdbm functions no longer work
Groups: php.dev 
Request: Send a blank email to php-dev+get-39420@lists.php.net to get a copy of this message
ID: 8016 Updated by: sniper Reported By: smarlowe@ihs.com Status: Closed Bug Type: DBM/DBA related Assigned To: Comments: Add --with-db to your configure line. DB extension is not enabled by default anymore. --Jani Previous Comments: --------------------------------------------------------------------------- [2000-11-28 15:53:26] smarlowe@ihs.com Compiling php with the --with-gdbm php will build and install properly, and with no warnings, claiming to be adding gdbm functionality, but attempts to use the dbmopen() command results in a fatal error message of "Call to undefined function: dbmopen() in /www/htdocs/test/dbm.html on line x" line producing the error is: $dbm = dbmopen ("lastseen", "w"); This problem did not exist with 4.0.0 through 4.0.2 configure line: ./configure --with-apxs=/www/bin/apxs --with-gdbm php.ini is stock --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=8016

« previous php.dev (#39420) next »