PHP 4.0 Bug #8051 Updated: libifsql.so: cannot open shared object file
| From: | gallard dot nicolas at cimaest dot msa dot fr | Date: | Fri, 01 Dec 2000 13:29:10 +0000 |
| Subject: | PHP 4.0 Bug #8051 Updated: libifsql.so: cannot open shared object file | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-39790@lists.php.net to get a copy of this message | ||
ID: 8051
User Update by: gallard.nicolas@cimaest.msa.fr
Status: Closed
Bug Type: Apache related
Description: libifsql.so: cannot open shared object file
I have add :
/usr/informix/lib/esql
/usr/informix/lib (for libifasf.so)
in file /etc/ld.so.conf
And after run ldconfig it GOOD !!!!
Thanks
Previous Comments:
---------------------------------------------------------------------------
[2000-11-30 21:24:49] sniper@php.net
Either add /usr/informix/lib/esql into /etc/ld.so.conf and run ldconfig (preferred)
or set LD_LIBRARY_PATH=/usr/informix/lib/esql environment variable
before starting Apache.
--Jani
---------------------------------------------------------------------------
[2000-11-30 09:31:23] gallard.nicolas@cimaest.msa.fr
When i want to start my server apache (1.3.12), i have this error :
[root@redhat bin]# ./apachectl start
Syntax error on line 256 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: libifsql.so: cannot open shared object file:
Aucun fichier ou repertoire de ce type
./apachectl start: httpd could not be started
The file libifsql.so is in /usr/informix/lib/esql/ and /etc/httpd/modules/
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=8051