Re: Re: cvs: php4 /pear DB.php /pear/DB common.phpmysql.php
| From: | Sebastian Bergmann | Date: | Mon, 04 Dec 2000 18:37:52 +0000 |
| Subject: | Re: Re: cvs: php4 /pear DB.php /pear/DB common.phpmysql.php | ||
| References: | 1 2 | Groups: | php.dev php.pear |
| Request: | Send a blank email to php-dev+get-40018@lists.php.net to get a copy of this message | ||
Chuck Hagenbuch wrote:
> > - $pdata = &$data[$i];
> > + $pdata = &$data[ $i ];
>
> Please stop making changes like this in the absence of a coding
> standards convention.
FIne with me.
> I find the form which you removed much more readable, and I'd
> really rather not see existing code creep in any particular
> direction unless we decide on a standard and convert everything to it.
Agreed, but are you really telling me that
function connect(&$dsn, $persistent = false) {
if (is_array($dsn)) {
$dsninfo = &$dsn;
} else {
$dsninfo = DB::parseDSN($dsn);
}
if (!$dsninfo || !$dsninfo['phptype']) {
return $this->raiseError();
}
is more readable as
function connect( &$dsn, $persistent = false )
{
if( is_array( $dsn ) )
{
$dsninfo = &$dsn;
}
else
{
$dsninfo = DB::parseDSN( $dsn );
}
if( !$dsninfo || !$dsninfo[ 'phptype' ] )
{
return $this->raiseError();
}
?
--
<? print implode( "", array_reverse( preg_split( "//", "dlrow laer
" .
"eht ot emoclew" ) ) ); /* visit http://www.sebastian-bergmann.de/ */ ?>