Re: PHP 4.0 Bug #8144: apache dumps core after libphp.so loaded

From: Date: Thu, 07 Dec 2000 03:27:56 +0000
Subject: Re: PHP 4.0 Bug #8144: apache dumps core after libphp.so loaded
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-40302@lists.php.net to get a copy of this message
Sascha, Yes, that was one of my guesses to try out - there's virtually nothing in any of the lists anywhere about LARGEFILE support, so that's what I was about to tackle. I just tried 404RC4, but I'm getting a symbol error now on startup: Cannot load /opt/httpd/1.3.14/libexec/libphp4.so into server: ld.so.1: /opt/httpd/1.3.14/sbin/httpd: fatal: relocation error: file /opt/httpd/1.3.14/libexec/libphp4.so: symbol php_if_stat64: referenced symbol not found I'm not sure where the symbol comes from, no luck grepping it out thus far. BTW, this is probably worthy of a FAQ topic (I have had much largefile distress over the last six months...I'm about to ban all files larger than 2G again), along with the proper fix for "duplicate symbol" error messages which I also figured out. Looking forward to getting this working! Thanks, David. ----- ** PLEASE NOTE ** This message was composed with the aid of a speech recognition system. Please be aware there may be some strange word usage. Many thanks.... On Thu, 7 Dec 2000, Sascha Schumann wrote: > > It seems to happen after a lstat64() or a close() on a file. > > Apache refused to dump core, even though permissions seem to be > > set fine, etc. > > Are you by chance using mod_perl or any other component which > caused Apache to build with LFS (Large File Support)? If yes, > using PHP 4.0.4RC4 or later will fix that. > > - Sascha > >

« previous php.dev (#40302) next »