PHP 4.0 Bug #6100 Updated: failed to use both mod_php3 and mod_php4
| From: | sniper@php.net | Date: | Thu, 07 Dec 2000 16:28:03 +0000 |
| Subject: | PHP 4.0 Bug #6100 Updated: failed to use both mod_php3 and mod_php4 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-40408@lists.php.net to get a copy of this message | ||
ID: 6100
Updated by: sniper
Reported By: udo.rader@profile.co.at
Status: Closed
Bug Type: *Install and Config
Assigned To:
Comments:
Reopen, if this still happens when using latest snapshot
from http://snaps.php.net/
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2000-11-01 09:03:27] sniper@php.net
Have you tried PHP4.0.3pl1 and does this
problem still exist?
--Jani
---------------------------------------------------------------------------
[2000-08-22 11:57:23] udo.rader@profile.co.at
yes, the options i used for configure were as follows:
- php3:
---------CUT------------
./configure
--with-mysql=/usr/local
--enable-track-vars
--enable-versioning
--with-gd
--without-imap
--with-apxs=/usr/local/httpd.games/bin/apxs
---------CUT------------
- php4:
---------CUT------------
./configure
--with-mysql=/usr/local
--enable-track-vars
--enable-versioning
--without-gd
--without-imap
--with-apxs=/usr/local/httpd.games/bin/apxs
---------CUT------------
any ideas?
---------------------------------------------------------------------------
[2000-08-11 03:51:53] mrobinso@php.net
Did you add '--with-apxs=/path/to/apxs' and
'--enable-versioning' to the config lines for
*both* php3 and php4?
It's required by both versions.
---------------------------------------------------------------------------
[2000-08-11 02:27:21] udo.rader@profile.co.at
for various reasons i need both mod_php3 and mod_php4 loaded into my apache 1.3.9 as dso's.
after recompiling and reinstalling apache using mod_so now, recompiling and reinstalling php3 to use
apxs and versioning and after all compiling and installing php4 i get the following strange error
messages in my httpd.error_log:
-------CUT----------
PHP Warning: Function registration failed - duplicate name - define in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - defined in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - each in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strlen in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - strcasecmp in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - error_reporting in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - leak in Unknown on line 0
PHP Warning: Function registration failed - duplicate name - function_exists in Unknown on line 0
PHP Warning: Basic Functions: Unable to register functions, unable to load in Unknown on line 0
-------CUT----------
obviously php4 rejects living with php3 ...
i am able to use the php3 dso without problems, if i outcomment the loadModule command for php4 in
httpd.conf, the same applies for the php4 dso counterwise.
on the other hand the php4 only dso usage results in a "Zero Sized Reply" if i use any
technology other than php4 (eg. mod_perl).
stats:
OS: suse linux 6.2
kernel: 2.2.10
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=6100