Re: PHP 4.0 Bug #8159 Updated: Error staring apache after compiling php4 with ldap
| From: | Orson Ka'ili | Date: | Thu, 07 Dec 2000 17:42:55 +0000 |
| Subject: | Re: PHP 4.0 Bug #8159 Updated: Error staring apache after compiling php4 with ldap | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-40479@lists.php.net to get a copy of this message | ||
I did that already and I still get the error.
Bug Database wrote:
> ID: 8159
> Updated by: sniper
> Reported By: okaili@lsil.com
> Status: Closed
> Bug Type: LDAP related
> Assigned To:
> Comments:
>
> Add the path to libldap30.so into LD_LIBRARY_PATH environment
> variable before starting Apache.
>
> e.g.
> # export LD_LIBRARY_PATH=/path/to/lib
>
> --Jani
>
> Previous Comments:
> ---------------------------------------------------------------------------
>
> [2000-12-07 12:15:37] okaili@lsil.com
> Compiled PHP4.0.4-dev fine with ldap support. When starting Apache I get this error:
>
> ----
> sudo ./apachectl start
> Syntax error on line 238 of /export3/apache/conf/httpd.conf:
> Cannot load /export3/apache/libexec/libphp4.so into server: ld.so.1: /export3/apache/bin/httpd:
> fatal: libldap30.so: open failed: No such file or directory
> ./apachectl start: httpd could not be started
> ----
>
> Apache - 1.3.14
> PHP - 4.0.4-dev release 1
> OS - Solaris 2.6
> LDAP - Netscape 4.12
>
> The file libldap30.so is in the ldap server lib directory.
>
> ---------------------------------------------------------------------------
>
> Full Bug description available at: http://bugs.php.net/?id=8159
--
// Orson Ka'ili