Re: PHP 4.0 Bug #8081 Updated: mail function fails (returns undef)
| From: | Keary Suska | Date: | Fri, 08 Dec 2000 00:53:37 +0000 |
| Subject: | Re: PHP 4.0 Bug #8081 Updated: mail function fails (returns undef) | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-40530@lists.php.net to get a copy of this message | ||
Commenting out the line solved the problem. I did not try emptying the path.
Is this a known bug or some kind of configuration problem? Will this
configuration hold with future updates or will it be deprecated?
Thanks
Keary Suska
Sys Admin
Frequent Flyer Services
http://www.webflyer.com/
> From: Bug Database <php-dev@lists.php.net>
> Date: 4 Dec 2000 00:07:39 -0000
> To: aksuska@webflyer.com
> Subject: PHP 4.0 Bug #8081 Updated: mail function fails (returns undef)
>
> ID: 8081
> Updated by: sniper
> Reported By: aksuska@webflyer.com
> Status: Feedback
> Bug Type: *Mail Related
> Assigned To:
> Comments:
>
> Have you tried leaving that sendmail path empty? If not
> try adding ; (commenting it) in front of it in php.ini.
>
> --Jani
>
> Previous Comments:
> ---------------------------------------------------------------------------
>
> [2000-12-02 21:32:56] aksuska@webflyer.com
> test Script:
> <?php
> $test_var = mail( "aksuska@webflyer.com", "Hi
> does this work?", "It is if you see this!" );
> print "The result is: $test_var";
> ?>
> No mail is sent, no error reported ($test_var is empty),
> nothing in syslogs. I also tried:
> <?php
> $fp = popen('/usr/sbin/sendmail -t', 'w');
> if($fp) {
> fputs($fp, "To: aksuska@webflyer.comn");
> fputs($fp, "Subject: testnn");
> fputs($fp, "Test of PHP manual mailer");
> fputs($fp, "n");
> pclose($fp);
> print "The result is: $test_var";
> }
> else {
> print "Can't open sendmail!";
> }
> ?>
> Which does not print the error message "can't open"
> nor sends an email (nothing in syslogs). Sendmail is
> indeed working, and works without error in Perl:
> open MAIL, "| /usr/lib/sendmail -t" # etc.
>
> BTW, I have the exact same problem on my LinuxPPC
> (basically RH) machine.
>
> Please help. Had no problem with earlier versions (last
> was 4.01pl2, I believe), just started when installed
> 403pl1.
>
> Location of sendmail: /usr/lib/sendmail
> sendmail_path (php.ini): /usr/lib/
>
> Configure:
> --with-apxs=/site/apache/bin/apxs
> --with-config-file-path=/site/etc --enable-magic-quotes
> --with-dbase --with-gdbm=/usr/local
> --with-mysql=/usr/local --with-gd=/usr/local
> --with-jpeg-dir=/usr/local --with-ttf=/usr/local
> --enable-calendar --enable-memory-limit
> --enable-trans-sid --enable-bcmath --with-mcrypt
> --with-mhash --with-zlib --with-ftp --enable-wddx
> --enable-ftp
>
> ---------------------------------------------------------------------------
>
>
> Full Bug description available at: http://bugs.php.net/?id=8081
>
>