PHP 4.0 Bug #8193: Compiling in imap support causes apache to fail on startup when loading php dso
| From: | joela at joelhq dot com | Date: | Mon, 11 Dec 2000 17:28:37 +0000 |
| Subject: | PHP 4.0 Bug #8193: Compiling in imap support causes apache to fail on startup when loading php dso | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-40872@lists.php.net to get a copy of this message | ||
From: joela@joelhq.com
Operating system: Redhat 6.2
PHP version: 4.0.3pl1
PHP Bug Type: PHP options/info functions
Bug description: Compiling in imap support causes apache to fail on startup when loading php dso
Platform Info:
Redhat Linux 6.2.
Apache 1.3.14 from RH RPM.
PHP 4.0.3pl1 compiled from source.
MySQL 3.23.28-gamma compiled from source.
Imap-2000 from RH RPM, including devel.
PHP Configure Options:
"./configure --with-apxs --with-mysql --with-xml --with-zlib --with-gd --with-gettext
--with-mcal --with-kerberos --with-openssl=/usr/bin/openssl --enable-wddx --with-java
--enable-sysvshm --enable-sysvsem --enable-debugger --enable-calendar --with-imap"
Problem:
When compiling php4 with the --with-imap option, compilation completes successfully, but apache
refuses to restart, throwing the following error:
"Starting httpd: Syntax error on line 875 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol:
SSL_CTX_set_tmp_rsa_callback"
Removing the --with-imap option allows the server to start correctly, with all other functionality
apparently operational.
I have spent the past week fiddling with the configure options (feeding the
--with-imap-path=/<dir>, etc.) to no avail.
Please Help!
--
Edit Bug report at: http://bugs.php.net/?id=8193&edit=1