Re: PHP 4.0 Bug #8193 Updated: Compiling in imap support causes apache to fail on startup when loading php dso
| From: | Joel Anderson | Date: | Mon, 11 Dec 2000 18:52:07 +0000 |
| Subject: | Re: PHP 4.0 Bug #8193 Updated: Compiling in imap support causes apache to fail on startup when loading php dso | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-40886@lists.php.net to get a copy of this message | ||
That did the trick! Thanks!
Joel
----- Original Message -----
From: <sniper@php.net>
To: <php-dev@lists.php.net>
Sent: Monday, December 11, 2000 11:40 AM
Subject: [PHP-DEV] PHP 4.0 Bug #8193 Updated: Compiling in imap support
causes apache to fail on startup when loading php dso
> ID: 8193
> Updated by: sniper
> Reported By: joela@joelhq.com
> Old-Status: Open
> Status: Closed
> Bug Type: PHP options/info functions
> Assigned To:
> Comments:
>
> Use --with-imap-ssl
> (try running ./configure --help)
>
>
> --Jani
>
> Previous Comments:
> --------------------------------------------------------------------------
-
>
> [2000-12-11 12:28:36] joela@joelhq.com
> Platform Info:
> Redhat Linux 6.2.
> Apache 1.3.14 from RH RPM.
> PHP 4.0.3pl1 compiled from source.
> MySQL 3.23.28-gamma compiled from source.
> Imap-2000 from RH RPM, including devel.
>
> PHP Configure Options:
>
>
"./configure --with-apxs --with-mysql --with-xml --with-zlib --with-gd --wit
h-gettext --with-mcal --with-kerberos --with-openssl=/usr/bin/openssl --enab
le-wddx --with-java --enable-sysvshm --enable-sysvsem --enable-debugger --en
able-calendar --with-imap"
>
> Problem:
>
> When compiling php4 with the --with-imap option, compilation completes
successfully, but apache refuses to restart, throwing the following error:
>
> "Starting httpd: Syntax error on line 875 of /etc/httpd/conf/httpd.conf:
> Cannot load /usr/lib/apache/libphp4.so into server:
/usr/lib/apache/libphp4.so: undefined symbol: SSL_CTX_set_tmp_rsa_callback"
>
> Removing the --with-imap option allows the server to start correctly, with
all other functionality apparently operational.
>
> I have spent the past week fiddling with the configure options (feeding
the --with-imap-path=/<dir>, etc.) to no avail.
>
> Please Help!
>
> --------------------------------------------------------------------------
-
>
>
> Full Bug description available at: http://bugs.php.net/?id=8193
>
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net
> For additional commands, e-mail: php-dev-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>