PHP 4.0 Bug #7087 Updated: error opening libclntsh.so.8.0

From: Date: Mon, 18 Dec 2000 15:36:04 +0000
Subject: PHP 4.0 Bug #7087 Updated: error opening libclntsh.so.8.0
Groups: php.dev 
Request: Send a blank email to php-dev+get-41756@lists.php.net to get a copy of this message
ID: 7087 Updated by: sniper Reported By: lpc2@stal.ru Old-Status: Open Status: Feedback Bug Type: Compile Failure Assigned To: Comments: Does this happen with latest snapshot from http://snaps.php.net/ ? --Jani Previous Comments: --------------------------------------------------------------------------- [2000-10-08 12:16:03] lpc2@stal.ru I use --with-oci8: get attention. See attach file debug.log: CONFIGURE: './configure' '--prefix=/u/wwww/php' '--with-apxs=/u/wwww/bin/apxs' '--with-mod_charset' '--with-oci8' '--enable-tracks-vars' '--enable-ftp' '--enable-sysvsem' '--enable-sysvshm' '--enable-sigchild' CC: cc CFLAGS: -g CPPFLAGS: CXX: CXXFLAGS: INCLUDES: -I/u/wwww/include -I$(top_builddir)/Zend -I$(top_srcdir) -I/u/source/php/ext/mysql/libmysql -I/oracle8/app/oracle/product/8.1.5/rdbms/demo -I/oracle8/app/oracle/product/8.1.5/network/public -I/oracle8/app/oracle/product/8.1.5/plsql/public LDFLAGS: -L/usr/ucblib -L/usr/ucblib -L/oracle8/app/oracle/product/8.1.5/lib -L/oracle8/app/oracle/product/8.1.5/lib LIBS: -lclntsh -lthread -ldshm -lgen -lm -lelf -ldl -lgen -lnsl -lsocket -lresolv -lresolv -lm -ldl -lcrypt -lsocket -lsocket DLIBS: SAPI: apache PHP_RPATHS: /usr/ucblib /oracle8/app/oracle/product/8.1.5/lib uname -a: UnixWare adm 5 7.1.0 i386 x86at SCO UNIX_SVR5 cc -o conftest -g -L/usr/ucblib -L/usr/ucblib -L/oracle8/app/oracle/product/8.1.5/lib -L/oracle8/app/oracle/product/8.1.5/lib conftest.c -lclntsh -lthread -ldshm -lgen -lm -lelf -ldl -lgen -lnsl -lsocket -lresolv -lresolv -lm -ldl -lcrypt -lsocket -lsocket 1>&5 UX:cc: WARNING: Use -Kthread instead of -lthread when linking with threads library; using -lthread directly may cause incorrect execution behavior. dynamic linker : ./conftest : error opening libclntsh.so.8.0 ----------------- if use --with-mysql: ./configure --prefix=/u/wwww/php --with-mysql --with-apxs=/u/wwww/bin/apxs --with-mod_charset --enable-tracks-vars --enable-ftp --enable-sysvsem --enable-sysvshm --enable-sigchild make make install # ./apachectl start Syntax error on line 1325 of /u/wwww/conf/httpd.conf: Cannot load /u/wwww/libexec/libphp4.so into server: dynamic linker: /u/wwww/bin/ httpd: relocation error: symbol not found: pow; referenced from: /u/wwww/libexec/libphp4.so ./apachectl start: httpd could not be started ??????? --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7087

« previous php.dev (#41756) next »