PHP 4.0 Bug #7982 Updated: Install with "java" option fails - $prefix/lib is not created b4 install
| From: | sniper@php.net | Date: | Tue, 19 Dec 2000 00:16:26 +0000 |
| Subject: | PHP 4.0 Bug #7982 Updated: Install with "java" option fails - $prefix/lib is not created b4 install | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-41814@lists.php.net to get a copy of this message | ||
ID: 7982
Updated by: sniper
Reported By: dan@stratabase.com
Old-Status: Open
Status: Closed
Bug Type: Compile Failure
Assigned To:
Comments:
Fixed in CVS now.
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2000-12-18 15:37:15] dan@stratabase.com
This test this was a waste of time, but I did it anyway (bad me).
Php default installs to /usr/local which has the system directory lib under it.
There for this problem would "Obviously", not exist.
However, remove the /usr/local/lib directory and you get the same problem.
---------------------------------------------------------------------------
[2000-12-18 10:49:56] sniper@php.net
What happens if you leave --prefix out?
--Jani
---------------------------------------------------------------------------
[2000-12-12 16:14:02] dan@stratabase.com
Is anyone looking into this yet?
---------------------------------------------------------------------------
[2000-11-26 20:31:40] dan@stratabase.com
./configure
--prefix=/www/php
--with-config-file-path=/www/apache/conf
--with-apache=../apache_1.3.14
--enable-ftp
--disable-debug
--with-unixODBC=/usr
--with-imap
--with-java
--with-mysql=/.usr
--with-pgsql=/usr
--with-mcrypt
--with-mhash
--enable-track-vars
make
mkdir -p /www/php/lib
make install
Notice how I create the lib directory.
I didn't have to do this until I added the java support in.
If I don't create that directory, everytime I do a complete fresh install the java file becomes
/www/php/lib as a file.
PS: Not related but.. I had read a post here awhile back saying that choosing your smtp server would
be an option for unix platforms when 4.0.3 came out, but it doesn't. Any idea on a time frame
for this?
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=7982