PHP 4.0 Bug #5773 Updated: ISAPI filter won't function with long directory name

From: Date: Sat, 30 Dec 2000 18:18:20 +0000
Subject: PHP 4.0 Bug #5773 Updated: ISAPI filter won't function with long directory name
Groups: php.dev 
Request: Send a blank email to php-dev+get-42695@lists.php.net to get a copy of this message
ID: 5773 Updated by: jmoore Reported By: steve@teamITS.com Old-Status: Open Status: Feedback Bug Type: IIS related Assigned To: Comments: Cant reproduce this on PHP ISAPI dll (PHP 4.0.4RC6), IIS 5, win2k. Think this is an IIS 4 problem which has been fixed in IIS 5. (It converts space to %20), this might be related to http://support.microsoft.com/support/kb/articles/Q164/1/44.asp?LN=EN-US&SD=gn&FR=0&qry=directory%20names&rnk=10&src=DHCS_MSPSS_gn_SRCH&SPR=IIS could you also try with long dirs with out spaces in, short dirnames with spaces and see if it has anything to do with spaces. James Previous Comments: --------------------------------------------------------------------------- [2000-09-08 14:41:18] steve@teamITS.com Yes, the same symptoms occur under Windows NT 4.0 / IIS 4.0. The CGI module still loads. --------------------------------------------------------------------------- [2000-09-04 20:15:38] sniper@php.net Does this problem still exist with php4.0.2 ? --Jani --------------------------------------------------------------------------- [2000-07-25 03:15:12] steve@teamITS.com Update: the ISAPI filter works under Windows 98 SE / PWS 4.0 in a long filename directory path. --------------------------------------------------------------------------- [2000-07-25 00:58:43] steve@teamITS.com If the PHP files are copied to a folder such as "D:Program FilesPHP" the ISAPI filter will not load. After copying the files to "D:inetsrvPHP" it loads. During the error condition the server returns error 500 (internal server error) for PHP pages. The CGI module loads both ways, with the long name in the configuration field as: "D:Program FilesPHPphp.exe" %s %s (however using quotes doesn't work for ISAPI...in fact without them MMC won't let you exit the dialog, claiming an invalid path). --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=5773

« previous php.dev (#42695) next »