PHP 4.0 Bug #8557: apache fails to start after compiling PHP - "can't load libphp4.so"
| From: | zhamm at secmgmt dot com | Date: | Thu, 04 Jan 2001 22:11:12 +0000 |
| Subject: | PHP 4.0 Bug #8557: apache fails to start after compiling PHP - "can't load libphp4.so" | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-42991@lists.php.net to get a copy of this message | ||
From: zhamm@secmgmt.com
Operating system: AIX 4.3.3
PHP version: 4.0.4
PHP Bug Type: Reproduceable crash
Bug description: apache fails to start after compiling PHP - "can't load libphp4.so"
Configured PHP 4.0.4 on AIX 4.3.3 using IBM C for AIX v.5
Apache 1.3.9 in /usr/local/etc/apache
Installed via the following:
export CC='cc -Dinline= -ma'
./configure --with-apxs=/usr/local/etc/apache/bin/apxs --with-mysql=/usr/local --with-gd=/usr/local
--with-ttf \ --with-informix
make; make install
everything appears to run fine (with the exception of some small errors about unrecognized
suffixes), but when I start apache, I get:
[root@p140 php-4.0.4]# /usr/local/etc/apache/bin/apachectl start
Syntax error on line 208 of /usr/local/etc/apache/conf/httpd.conf:
Cannot load /usr/local/etc/apache/libexec/libphp4.so into server: dlopen:
/usr/local/etc/apache/libexec/libphp4.so: No such file or directory
/usr/local/etc/apache/bin/apachectl start: httpd could not be started
If I run configure with ONLY the --with-apxs and --with-mysql options, it compiles and installs, and
apache runs fine. If I remove --with-informix, same thing. If I remove the --with-gd and related,
same thing.
I've set INFORMIXDIR appropriately, and have the informix SDK installed (I've built this
module successfully in Linux).
I've installed the gd,zlib,libjpeg,and freetype from bull.de, and manually built them as well.
No difference.
Apache modules installed:
[root@p140 local]# /usr/local/etc/apache/bin/httpd -l
Compiled-in modules:
http_core.c
mod_env.c
mod_log_config.c
mod_mime.c
mod_negotiation.c
mod_status.c
mod_include.c
mod_autoindex.c
mod_dir.c
mod_cgi.c
mod_asis.c
mod_imap.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_access.c
mod_auth.c
mod_so.c
mod_setenvif.c
--
Edit Bug report at: http://bugs.php.net/?id=8557&edit=1