PHP 4.0 Bug #8539 Updated: undefined symbol: phpi_get_le_gd
| From: | sniper@php.net | Date: | Sat, 06 Jan 2001 04:39:30 +0000 |
| Subject: | PHP 4.0 Bug #8539 Updated: undefined symbol: phpi_get_le_gd | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-43118@lists.php.net to get a copy of this message | ||
ID: 8539
Updated by: sniper
Reported By: salaj@pronixnet.sk
Old-Status: Open
Status: Duplicate
Bug Type: Apache related
Assigned To:
Comments:
Duplicate of bug report #8437.
Removing 'shared' from the --with-gd option is a temporary workaround.
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2001-01-03 14:56:41] salaj@pronixnet.sk
My configure parameters:
./configure --with-apxs=/usr/local/apache/bin/apxs --with-openssl=/usr/local/ssl --enable-calendar
--enable-ctype --enable-dbase --enable-exif --enable-filepro --enable-ftp
--with-gd=shared,/usr/local --enable-gd-imgstrttf --with-ttf=/usr/local --with-t1lib=/usr/local
--with-hyperwave --with-imap=/root/imap-2000a --with-mysql=/usr/local --with-pdflib=/usr/local
--with-tiff-dir=/usr/local --with-jpeg-dir=/usr/local --enable-trans-sid --enable-shmop
--enable-sockets --with-regex=php --enable-sysvsem --enable-sysvshm --enable-wddx --enable-yp
--with-zlib=/usr/local
Configure and make without any problems, but when I try to start Apache, I get an error:
Syntax error on line 208 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined symbol: phpi_get_le_gd
./apachectl start: httpd could not be started
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=8539