PHP 4.0 Bug #8340 Updated: Unable to handle MS SQL's ntext data type. Fails with FATAL: emalloc(): Unable
| From: | cynic@php.net | Date: | Sat, 06 Jan 2001 08:18:03 +0000 |
| Subject: | PHP 4.0 Bug #8340 Updated: Unable to handle MS SQL's ntext data type. Fails with FATAL: emalloc(): Unable | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-43147@lists.php.net to get a copy of this message | ||
ID: 8340
Updated by: cynic
Reported By: myers@fil.org
Old-Status: Open
Status: Duplicate
Bug Type: ODBC related
Assigned To:
Comments:
duplicate of #8541
fmk@php.net:
This is not an error in the MS SQL extension, as you are using ODBC functions to fetch data.
Microsofts new datatypes ntext nad nvarchar is not suported in the MS SQL extension, as they are not
supported in Microsofts C-library. The will always be returned as a varchar with a max length of 255
bytes.
Previous Comments:
---------------------------------------------------------------------------
[2000-12-20 12:23:02] myers@fil.org
Using MS SQL via ODBC. Any time I tried to select a field from the database that had the type
'ntext' it failed with this error:
FATAL: emalloc(): Unable to allocate 1073741824 bytes
What's weird is that this is the same amount of memory that someone ran into in bug #1299, thus
I think we're on to the same bug.
also check out http://lists.omnipotent.net/php3/200003/msg00552.html
http://infosoc.uni-koeln.de/pipermail/php/Week-of-Mon-20000214/014693.html
(in Germany... not sure what their saying but the number is the same).
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=8340