PHP 4.0 Bug #8055 Updated: doesn't recognize ntext data type

From: Date: Sat, 06 Jan 2001 09:38:47 +0000
Subject: PHP 4.0 Bug #8055 Updated: doesn't recognize ntext data type
Groups: php.dev 
Request: Send a blank email to php-dev+get-43155@lists.php.net to get a copy of this message
ID: 8055 Updated by: cynic Reported By: jeremy.brooks@bams.com Old-Status: Open Status: Duplicate Bug Type: MSSQL related Assigned To: Comments: duplicate of #8541 fmk@php.net: This is not an error in the MS SQL extension, as you are using ODBC functions to fetch data. Microsofts new datatypes ntext nad nvarchar is not suported in the MS SQL extension, as they are not supported in Microsofts C-library. The will always be returned as a varchar with a max length of 255 bytes. Previous Comments: --------------------------------------------------------------------------- [2000-11-30 12:54:11] jeremy.brooks@bams.com On MS SQL Server 7 PHP NT Server 4 sp6 Apache 1.3.11...In a SELECT statement containing a reference to an ntext (national text) data field; PHP either ignores everything in the script after the cursor declaration or throws an Apache error 500 (server config error). Converted ntext to text, works fine. INSERT's work fine in ntext, however. nvarchar seems to work OK. --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=8055

« previous php.dev (#43155) next »