PHP 4.0 Bug #6899 Updated: OCI8 doesn't work with ORALCE 8.16 for linux on redhat 6.2

From: Date: Tue, 09 Jan 2001 07:39:32 +0000
Subject: PHP 4.0 Bug #6899 Updated: OCI8 doesn't work with ORALCE 8.16 for linux on redhat 6.2
Groups: php.dev 
Request: Send a blank email to php-dev+get-43512@lists.php.net to get a copy of this message
ID: 6899 Updated by: steinm Reported By: eric@otherways.com Status: Feedback Bug Type: OCI8 related Assigned To: Comments: It works here on a SuSE 6.x using php 4.03 if at least ORACLE_HOME is set Previous Comments: --------------------------------------------------------------------------- [2001-01-07 19:48:25] sniper@php.net Have you set all the needed environment variables before starting apache? See http://www.php.net/manual/ref.oci8.php for more info. --Jani --------------------------------------------------------------------------- [2000-09-27 04:51:19] eric@otherways.com I thought it might be bug, because the Oralce 8.16 for linux is quite new. after successful complie and installation, when tried to access oracle like this: <? ocilogon("system","test","TEST"); ?> I get this error Warning: _oci_open_server: Error while trying to retrieve text for error ORA-12546 in /home/otherways/htdocs/testo.php on line 2 ORA-12546 TNS:permission denied Cause: User has insufficient privileges to perform the requested operation. Action: Acquire necessary privileges and try again. but I use "sqlplus system/test@TEST", it totally ok. why php can't access oracle? but oracle 8.16 for solaris sparc + apache1.3.12 + php4.02 + solaris 7 have no such a problem, it work great! it seems only happen my linux(redhat6.2)+ oracle 8.16 for linux + php4.02 --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=6899

« previous php.dev (#43512) next »