Re: PHP 4.0 Bug #8575: && [PHP-INST] PHP 4.0.4 - unable to configure under Solaris 2.6 (explanation)
| From: | Olivier Bourgeois | Date: | Tue, 09 Jan 2001 13:41:10 +0000 |
| Subject: | Re: PHP 4.0 Bug #8575: && [PHP-INST] PHP 4.0.4 - unable to configure under Solaris 2.6 (explanation) | ||
| References: | 1 | Groups: | php.dev php.install |
| Request: | Send a blank email to php-dev+get-43556@lists.php.net to get a copy of this message | ||
Hi Maciek Uhlig,
thanks for posting this message to the list : you answered a question I was lacking a answer since a few weeks now. The bug you describe is not only "available" ;-) on Solaris 2.6 : I've got the same bug on a RedHat 6.2, and I found yesterday somone described the same on a slackware 7.0 in php.net bug DB.And 3 or 4 people posted to the list with the same problem: "undefined symbol compress & uncompress".
As I'm not an expert with autoconf/automake and ld, I solved the problem by rebuilding MySQL from the tarball (wich is I must admit a much less elegant way to solve the problem). But that was not answering my question.
So you did ! Thanks :)
Maciek Uhlig wrote:
Introduction: OK, so you don't believe PHP 4.0.4 configure fails under Solaris 2.6? :-) Ju st read on. You'll get known how it is possible at all. Below you'll find th e complete history as well as the description what was going on and why it f ailed (even two times). [SNIP]