PHP 4.0 Bug #8766: couldn't connect to MySQL server which has default character set cp1251
| From: | crazy50s at yahoo dot com | Date: | Wed, 17 Jan 2001 17:56:07 +0000 |
| Subject: | PHP 4.0 Bug #8766: couldn't connect to MySQL server which has default character set cp1251 | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-44398@lists.php.net to get a copy of this message | ||
From: crazy50s@yahoo.com
Operating system: FreeBSD 3.3
PHP version: 4.0 Latest CVS (17/01/2001)
PHP Bug Type: MySQL related
Bug description: couldn't connect to MySQL server which has default character set cp1251
FreeBSD 3.3 -RELEASE
Apache/1.3.14
PHP 4.0.5-dev compiled as DSO --with-mysql --with-apxs
MYSQL 3.23.30
compiled with
--default-character-set = cp1251 (this is charset #14 in
/usr/local/mysql/share/mysql/charsets/Index)
have no problem connecting to it from mysql/mysqladmin clients
when trying to mysql_connect() from PHP script, got this error message
...MySQL Connection Failed: Can't initialize character set 14 (path: default)....
installing PHP 4.0.3pl1 solved the problem :)
check out this URL
http://x63.deja.com/[ST_rn=ps]/getdoc.xp?AN=714791711&CONTEXT=979753585.1563033636&hitnum=8
for description of this bug (or maybe feature) by another user
I find it amusing that 4.0.4 and 4.0.4pl1 do not work because of bug #8738... and 4.0.5-dev (CVS
snapshot) doesn't work either because of this.
thanks
--
Edit Bug report at: http://bugs.php.net/?id=8766&edit=1