Re: Proposal for updating the PDF-extension

From: Date: Wed, 24 Jan 2001 14:07:09 +0000
Subject: Re: Proposal for updating the PDF-extension
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-44897@lists.php.net to get a copy of this message
maybe they should be pdf_find_font, pdf_add_local_link etc? that would be more consistent with the func-naming convention, I guess, but I'm in no position to decide this. but I definitely think that it should be either underscore everywhere, or just between the ext. prefix and the rest of the name (i. e. pdf_findfont, pdf_injectasmanywordasyouseefit), or whatever, but it should be consistent. that is, don't mix pdf_open_file with pdf_add_locallink, because that only confuse folks. and the consensus (at least I got it it's agreed on) is pdf_add_local_link-like names. At 14:26 24.1. 2001, Rainer Schaaf wrote the following: -------------------------------------------------------------- >New functions (available in PDFlib, but not yet in PHP): >======================================================== > > PHP_FE(pdf_new, NULL) /* new function */ > PHP_FE(pdf_delete, NULL) /* new function */ > PHP_FE(pdf_open_file, NULL) /* new function */ > PHP_FE(pdf_get_buffer, NULL) /* new function */ > PHP_FE(pdf_findfont, NULL) /* new function */ > PHP_FE(pdf_setfont, NULL) /* new function */ > PHP_FE(pdf_setpolydash, NULL) /* new function: not yet >finished */ > PHP_FE(pdf_concat, NULL) /* new function */ > PHP_FE(pdf_open_CCITT, NULL) /* new function */ > PHP_FE(pdf_open_image, NULL) /* new function */ > PHP_FE(pdf_attach_file, NULL) /* new function */ > PHP_FE(pdf_add_note, NULL) /* new function */ > PHP_FE(pdf_attach_file, NULL) /* new function */ > PHP_FE(pdf_add_note, NULL) /* new function */ > PHP_FE(pdf_add_locallink, NULL) /* new function */ > PHP_FE(pdf_add_launchlink, NULL)/* new function */ > > >these functions got some more (optional) parameters. >==================================================== > > PHP_FE(pdf_open_image_file, NULL) /* new parameters: [char >*stringparam, > int intparam] */ > PHP_FE(pdf_stringwidth, NULL) /* new parameters: [int font, >float size >] */ > >The function pdf_add_outline was renamed to pdf_add_bookmark and >PHP_FALIAS(pdf_add_outline, pdf_add_bookmark, NULL) will map it to the >old name. > > >Possible incompatible changes in the PHP-PDFlib API: >==================================================== > >We removed the PHP-Resource-handling of PDFlib Resources in the >wrapper-code on most places. This was neccesary to return the documented > >returnvalues. The proper resourcehandling is done by PDFlib internaly so > >it seems to be unnecceary that the PHP-extension tries to do the work >again. > >PDF_open_image() PDF_open_CCITT() and PDF_open_image_file() now return >an Integer, so the returnvalue is no longer handeld as a PHP-resource. >Functions like PDF_get_value(=, PDF_close_image(), PDF_place_image(), >pdf_get_image_width(), pdf_get_image_height() are changed to reflect >this. > >PDF_add_bookmark() now returns an Integer. > > >Some new features available now: >================================ > >PDF_new() + PDF_open_file replaces PDF_open() and PDF_delete() allows to > >cleanup the whole PDFlib-stuff. > >=> now you may create many different PDF_files with one PDF-Object. >=> PDF_set_parameter($p, "compatibility", ...) now works > >PDF_get_buffer() now works this allows the users to generate PDF-Files >in memory with full control over the generated PDF-File. > >+ all the missing functions of the PDFlib 3.x API (see above). > > >All your input is welcome. > >Rainer > >-- >Rainer Schaaf rjs@pdflib.com http://www.pdflib.com >_______PDFlib - a library for generating PDF on the fly________ > > > >-- >PHP Development Mailing List <http://www.php.net/> >To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net >For additional commands, e-mail: php-dev-help@lists.php.net >To contact the list administrators, e-mail: php-list-admin@lists.php.net ------end of quote------ ____________________________________________________________ Cynic: A member of a group of ancient Greek philosophers who taught that virtue constitutes happiness and that self control is the essential part of virtue. cynic@mail.cz

« previous php.dev (#44897) next »