PHP 4.0 Bug #8977: Cannot load /usr/lib/apache/libphp4.so into server:
| From: | steve at bassi dot com | Date: | Mon, 29 Jan 2001 10:37:42 +0000 |
| Subject: | PHP 4.0 Bug #8977: Cannot load /usr/lib/apache/libphp4.so into server: | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-45196@lists.php.net to get a copy of this message | ||
From: steve@bassi.com
Operating system: cobalt RAQ3 linux redhat
PHP version: 4.0.4pl1
PHP Bug Type: *Install and Config
Bug description: Cannot load /usr/lib/apache/libphp4.so into server:
when configuring PHP4 with curl-7.6 (./configure --with-mysql --with-apxs --with-curl
--enable-track-vars)
when apache loads the libphp4.so, it detects that it also needs to load the libcurl.so object.
But,it seems as if the full path to the libcurl.so file is not included in libphp and then, since
libcurl is stored in a separate custom directory, it doesn't find it.
You get an error message:
Setting up Web Service: Syntax error on line 32 of /etc/httpd/conf/httpd.conf: Cannot load
/usr/lib/apache/libphp4.so into server: libcurl.so.0:
cannot open shared object file: No such file or directory
/usr/sbin/httpd
However PHP configures fine with an old version of curl, namely libcurl 7.4.2
--
Edit Bug report at: http://bugs.php.net/?id=8977&edit=1