PHP 4.0 Bug #8977 Updated: Cannot load /usr/lib/apache/libphp4.so into server:
| From: | sniper@php.net | Date: | Mon, 29 Jan 2001 23:35:21 +0000 |
| Subject: | PHP 4.0 Bug #8977 Updated: Cannot load /usr/lib/apache/libphp4.so into server: | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-45264@lists.php.net to get a copy of this message | ||
ID: 8977
Updated by: sniper
Reported By: steve@bassi.com
Old-Status: Open
Status: Bogus
Bug Type: *Install and Config
Assigned To:
Comments:
You should add the install path of curl to --with-curl option.
e.g. --with-curl=/opt/curl
And also you have to put the path of the libraries into /etc/ld.so.conf:
/opt/curl/lib
and then run:
# /sbin/ldconfig
If this doesn't help, ask further questions on php-install@lists.php.net
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2001-01-29 05:37:42] steve@bassi.com
when configuring PHP4 with curl-7.6 (./configure --with-mysql --with-apxs --with-curl
--enable-track-vars)
when apache loads the libphp4.so, it detects that it also needs to load the libcurl.so object.
But,it seems as if the full path to the libcurl.so file is not included in libphp and then, since
libcurl is stored in a separate custom directory, it doesn't find it.
You get an error message:
Setting up Web Service: Syntax error on line 32 of /etc/httpd/conf/httpd.conf: Cannot load
/usr/lib/apache/libphp4.so into server: libcurl.so.0:
cannot open shared object file: No such file or directory
/usr/sbin/httpd
However PHP configures fine with an old version of curl, namely libcurl 7.4.2
---------------------------------------------------------------------------
Full Bug description available at: http://bugs.php.net/?id=8977