PHP 4.0 Bug #7712 Updated: Problem with DSO and Apache -- occurs in upgrade from 4.0.3 to 4.0.3pl1

From: Date: Tue, 30 Jan 2001 09:10:44 +0000
Subject: PHP 4.0 Bug #7712 Updated: Problem with DSO and Apache -- occurs in upgrade from 4.0.3 to 4.0.3pl1
Groups: php.dev 
Request: Send a blank email to php-dev+get-45327@lists.php.net to get a copy of this message
ID: 7712 Updated by: sniper Reported By: tobkin@tobkin.com Old-Status: Feedback Status: Closed Bug Type: Apache related Assigned To: Comments: No feedback. Considered fixed in PHP 4.0.4pl1. --Jani Previous Comments: --------------------------------------------------------------------------- [2000-12-04 09:28:19] sniper@php.net Please try PHP 4.0.4RC3 to see if this happens with it: http://www.php.net/distributions/php-4.0.4RC3.tar.gz --Jani --------------------------------------------------------------------------- [2000-11-09 01:48:48] tobkin@tobkin.com ./apachectl start Syntax error on line 228 of /home/src/apache/conf/httpd.conf: Cannot load /home/src/apache/libexec/libphp4.so into server: ld.so.1: /home/src/apache/bin/httpd: fatal: relocation error: file /home/src/apache/libexec/libphp4.so: symbol sapi_get_stat: referenced symbol not found ./apachectl start: httpd could not be started This occurs with any combination of configure options from something as simple as: ./configure --with-apxs=/home/src/apache/bin/apxs to more complex options. The common thread is that I'm compiling it as a shared object for apache (which is compiled with DSO support). It seems to be something that changed from 4.0.3 to 4.0.3pl1. I'm able to successfully go back to 4.0.3 as a dynamic shared object for apache just fine. Feel free to contact me if you have ideas for a solution or need more information. Thanks, // Chris tobkin@tobkin.com --------------------------------------------------------------------------- Full Bug description available at: http://bugs.php.net/?id=7712

« previous php.dev (#45327) next »