Re: PHP 4.0 Bug #8984: Intermittent TNS-12154 (cannot resolve service name) error
| From: | Thomas Fromm | Date: | Tue, 30 Jan 2001 14:03:41 +0000 |
| Subject: | Re: PHP 4.0 Bug #8984: Intermittent TNS-12154 (cannot resolve service name) error | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-45404@lists.php.net to get a copy of this message | ||
Hi,
> This is basically a rehash of bugs #4307, #5569 & #8232.
>
> Running PHP 4.0.1pl1 as an Apache 3.1.12 module, I often run into this problem during
> OCILogon() calls.
>
> Regarding the solution to #4307 - ALL oracle-related env vars I can think of are set before
> Apache is started. The /etc/rc3.d script that starts apache sources a file setting the lot of them
> before starting the server.
>
> The solution I saw in #5569 - make user "nobody" a member of group "dba" -
> is, frankly, unacceptable (and I haven't even tried it). I have a public portal to run, and
> can't afford the secrity hole.
>
> Essentially, I am also reiterating bug report #8232, which I see has remained open for over a
> month now.
>
> The problem appears intermittently in virtually all places that OCILogon() is used, so I see
> now point in osting yet another code example.
you have to set the ORA_NLS33
e.g.:
ORA_NLS33=/u01/oracle/product/8.1.6/ocommon/nls/admin/data
and the ORACLE_HOME
e.g.:
ORACLE_HOME=/u01/oracle/product/8.1.6/
befor starting the apache and the tnsnames.ora must be readable by wwwrun (or
unser whatever your apache runs)
thats solved the problem at my side...
regards,
thomas
--
--------------------------------------------------------------------------
http://phporacleadmin.org http://tfromm.com http://inubit.com
"go away or I will replace You with a small PHP script!"