PHP 4.0 Bug #9436: SUN_LEN and hstrerror undefined
| From: | lex at beep dot ru | Date: | Sat, 24 Feb 2001 16:09:14 +0000 |
| Subject: | PHP 4.0 Bug #9436: SUN_LEN and hstrerror undefined | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-47378@lists.php.net to get a copy of this message | ||
From: lex@beep.ru
Operating system: HP-UX 11
PHP version: 4.0.4pl1
PHP Bug Type: Sockets related
Bug description: SUN_LEN and hstrerror undefined
Apache with PHP module does not start with following error:
root@car:/lhome/lex/src/php-4.0.4pl1> /opt/apache/bin/apachectl start
/usr/lib/dld.sl: Unresolved symbol: SUN_LEN (code) from /opt/apache/libexec/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: hstrerror (code) from /opt/apache/libexec/libphp4.sl
Syntax error on line 238 of /opt/apache/conf/httpd.conf:
Cannot load /opt/apache/libexec/libphp4.sl into server: No such file or directory
/opt/apache/bin/apachectl start: httpd could not be started
PHP was compiled with following parameters:
CFLAGS="-O2" LDFLAGS="-lcl -lpthread" ./configure
--with-apxs=/opt/apache/bin/apxs --with-config-file-path=/opt/php/conf
--with-exec-dir=/opt/apache/cgi-bin --enable-calendar --with-zlib-dir=/opt/zlib --enable-ftp
--enable-gd-imgstrttf --with-gd=/opt/gd --with-jpeg-dir=/opt/jpeg-6 --with-xpm-dir=/opt/xpm
--with-ttf=/opt/freetype --with-oci8=/d/db01/app/oracle/product/8.0.6 --with-zlib-dir=/opt/zlib
--enable-sockets --enable-sysvsem --enable-sysvshm --enable-yp --with-zlib=/opt/zlib
--enable-inline-optimization --enable-memory-limit --prefix=/opt/php --with-png-dir=/opt/libpng
--with-gettext=/opt/gettext --without-mysql
--
Edit Bug report at: http://bugs.php.net/?id=9436&edit=1