PHP 4.0 Bug #9472: Apache refuses to start when trying to load php DSO module

From: Date: Tue, 27 Feb 2001 00:36:00 +0000
Subject: PHP 4.0 Bug #9472: Apache refuses to start when trying to load php DSO module
Groups: php.dev 
Request: Send a blank email to php-dev+get-47593@lists.php.net to get a copy of this message
From: thegreengrinch@operamail.com Operating system: Red Hat Linux 7.0 PHP version: 4.0.4pl1 PHP Bug Type: Apache related Bug description: Apache refuses to start when trying to load php DSO module LoadModule php4_module libexec/libphp4.so When the previous line is present in the httpd.conf file, Apache will not load when the "./apachectl restart" command is executed. I get the error: [root@ip234-164 bin]# ./apachectl restart ./apachectl restart: configuration broken, ignoring restart ./apachectl restart: (run 'apachectl configtest' for details) I then run: [root@ip234-164 bin]# ./apachectl configtest Syntax error on line 207 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: undefined symbol: uncompress PHP was configured as follows: ./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local/php --with-track-vars --with-trans-id -- Edit Bug report at: http://bugs.php.net/?id=9472&edit=1

« previous php.dev (#47593) next »