PHP 4.0 Bug #9490: removing config.cache but still getting same install as before

From: Date: Wed, 28 Feb 2001 00:18:24 +0000
Subject: PHP 4.0 Bug #9490: removing config.cache but still getting same install as before
Groups: php.dev 
Request: Send a blank email to php-dev+get-47650@lists.php.net to get a copy of this message
From: giluxxx@hotmail.com Operating system: linux redhat6.2 PHP version: 4.0.4pl1 PHP Bug Type: *Install and Config Bug description: removing config.cache but still getting same install as before i compiled php with gd and all was well. a few days later on i upgraded gd and restarted apache, apache: Starting httpd: Syntax error on line 250 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/libgd.so.1: undefined symbol: png_set_dither make output: could not find libgd.(a|so) anywhere in /usr/lib (although its there for sure) to get php up and running again without any loss of time i decided to do a recompile without gd. so i recompiled php: rm config.cache ./configure --with-apxs make make install but apache still gives the same error when starting although gd isnt even compiled into php this time!! this made me think. so i decided to to try a few different versions of gd and kept getting exactly the same apache error everytime although gd was working fine for webalizer.. solution: delete the whole source dir. untar src again and compile again. now it works. so removing the config.cache doesnt give you a clean install at all, it seems to repeat the first install exactly everytime, although the INSTALL file says that removing the config.cache file should get you a fresh install. maybe this isnt a bug but a feature, but i dont seem to remember php did this in previous versions....? -- Edit Bug report at: http://bugs.php.net/?id=9490&edit=1

« previous php.dev (#47650) next »