PHP 4.0 Bug #9492: libmysqlclient.so.6 not found

From: Date: Wed, 28 Feb 2001 06:14:47 +0000
Subject: PHP 4.0 Bug #9492: libmysqlclient.so.6 not found
Groups: php.dev 
Request: Send a blank email to php-dev+get-47654@lists.php.net to get a copy of this message
From: loosecannon@411.com Operating system: Soalris 2.6 PHP version: 4.0.4pl1 PHP Bug Type: *Install and Config Bug description: libmysqlclient.so.6 not found Compiling PHP4 as an Apache DSO module with the following: ./configure --with-apxs=/www/server/apache/bin/apxs --with-yaz=/www/src/yaz-1.6 --with-mysql=/www/mysql --with-sybase=/usr/local/sybase/client --with-xml --enable-ftp --with-gd=/www/src/gd1.2 --disable-pear --with-dbase --enable-libgcc No complaints through the configure, make or make install process but when I go to test Apache with the new AddModule & LoadModule statments added to httpd.conf, I get: Wed12:03:11am|/www/server/apache/libexec>../bin/apachectl configtest Syntax error on line 234 of /www/server/apache/conf/httpd.conf: Cannot load /www/server/apache/libexec/libphp4.so into server: ld.so.1: /www/server/apache /bin/httpd: fatal: libmysqlclient.so.6: open failed: No such file or directory I've seen mention in the other bug reports that on Linux systems you can change the ld configuration. Any suggestions for a Solaris environment?? -- Edit Bug report at: http://bugs.php.net/?id=9492&edit=1

« previous php.dev (#47654) next »