PHP 4.0 Bug #9490 Updated: removing config.cache but still getting same install as before
| From: | sniper@php.net | Date: | Thu, 01 Mar 2001 22:12:33 +0000 |
| Subject: | PHP 4.0 Bug #9490 Updated: removing config.cache but still getting same install as before | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-47731@lists.php.net to get a copy of this message | ||
ID: 9490
Updated by: sniper
Reported By: giluxxx@hotmail.com
Old-Status: Open
Status: Bogus
Bug Type: *Install and Config
Assigned To:
Comments:
Correct way to do reconfigures:
# rm config.cache
# ./configure (+ the options wanted)
# make clean ; make depend ; make ; make install
'make clean' might have been enough in your case.
--Jani
Previous Comments:
---------------------------------------------------------------------------
[2001-02-27 19:18:24] giluxxx@hotmail.com
i compiled php with gd and all was well.
a few days later on i upgraded gd and restarted apache,
apache:
Starting httpd: Syntax error on line 250 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/libgd.so.1: undefined symbol:
png_set_dither
make output: could not find libgd.(a|so) anywhere in /usr/lib (although its there for sure)
to get php up and running again without any loss of time i decided to do a recompile without gd.
so i recompiled php:
rm config.cache
./configure --with-apxs
make
make install
but apache still gives the same error when starting although gd isnt even compiled into php this
time!!
this made me think.
so i decided to to try a few different versions of gd and kept getting exactly the same apache error
everytime although gd was working fine for webalizer..
solution:
delete the whole source dir.
untar src again and compile again.
now it works.
so removing the config.cache doesnt give you a clean install at all, it seems to repeat the first
install exactly everytime, although the INSTALL file says that removing the config.cache file should
get you a fresh install.
maybe this isnt a bug but a feature, but i dont seem to remember php did this in previous
versions....?
---------------------------------------------------------------------------
ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=9490&edit=2