PHP 4.0 Bug #9492 Updated: libmysqlclient.so.6 not found

From: Date: Thu, 01 Mar 2001 22:20:42 +0000
Subject: PHP 4.0 Bug #9492 Updated: libmysqlclient.so.6 not found
Groups: php.dev 
Request: Send a blank email to php-dev+get-47733@lists.php.net to get a copy of this message
ID: 9492 Updated by: sniper Reported By: loosecannon@411.com Old-Status: Open Status: Bogus Bug Type: *Install and Config Assigned To: Comments: # export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/www/mysql/lib/mysql/ (that's where my mysql libs are, change it to where yours are) before starting apache. It's the similar thing as in Linux is the 'ldconfig' command. --Jan Previous Comments: --------------------------------------------------------------------------- [2001-02-28 01:14:46] loosecannon@411.com Compiling PHP4 as an Apache DSO module with the following: ./configure --with-apxs=/www/server/apache/bin/apxs --with-yaz=/www/src/yaz-1.6 --with-mysql=/www/mysql --with-sybase=/usr/local/sybase/client --with-xml --enable-ftp --with-gd=/www/src/gd1.2 --disable-pear --with-dbase --enable-libgcc No complaints through the configure, make or make install process but when I go to test Apache with the new AddModule & LoadModule statments added to httpd.conf, I get: Wed12:03:11am|/www/server/apache/libexec>../bin/apachectl configtest Syntax error on line 234 of /www/server/apache/conf/httpd.conf: Cannot load /www/server/apache/libexec/libphp4.so into server: ld.so.1: /www/server/apache /bin/httpd: fatal: libmysqlclient.so.6: open failed: No such file or directory I've seen mention in the other bug reports that on Linux systems you can change the ld configuration. Any suggestions for a Solaris environment?? --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=9492&edit=2

« previous php.dev (#47733) next »