PHP 4.0 Bug #8506 Updated: CGI PHP doesn't erase the #!/path/to/php

From: Date: Tue, 06 Mar 2001 13:01:40 +0000
Subject: PHP 4.0 Bug #8506 Updated: CGI PHP doesn't erase the #!/path/to/php
Groups: php.dev 
Request: Send a blank email to php-dev+get-48030@lists.php.net to get a copy of this message
ID: 8506 Updated by: stas Reported By: vladnc@hotmail.com Old-Status: Open Status: Feedback Old-Bug Type: Scripting Engine problem Bug Type: *Web Server problem Assigned To: Comments: What is your apache configuration for PHP scripts? Previous Comments: --------------------------------------------------------------------------- [2001-01-02 15:41:55] vladnc@hotmail.com And if you still have any doubts, thinking that Apache has reconized the file extension and is not using the cgi version, try http://book.ecompare-corp.com/cgi-bin/vxml/engines/kbb/phpinfo.vxml The output is the same. And if you read the php output on both pages you'll see that PHP is run as CGI (Server API CGI). --------------------------------------------------------------------------- [2001-01-02 15:29:53] vladnc@hotmail.com "PHP does not require the first line that you are including unlike perl due to the way its set up in apache." You're wrong. PHP is not set up at all in Apache. Look what happens if I delete the first line: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD> <TITLE>500 Internal Server Error</TITLE> </HEAD><BODY> <H1>Internal Server Error</H1> The server encountered an internal error or misconfiguration and was unable to complete your request.<P> Please contact the server administrator, webmaster@book.ecompare-corp.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.<P> More information about this error may be available in the server error log.<P> <HR> <ADDRESS>Apache/1.3.12 Server at book.ecompare-corp.com Port 80</ADDRESS> </BODY></HTML> Server error log: [Mon Jan 1 16:00:34 2001] [error] [client 212.54.118.28] Premature end of script headers: /home/httpd/cgi-bin/vxml/engines/kbb/phpinfo2.php --------------------------------------------------------------------------- [2001-01-02 14:49:34] jmoore@php.net PHP does not require the first line that you are including unlike perl due to the way its set up in apache. --------------------------------------------------------------------------- [2000-12-31 21:13:47] vladnc@hotmail.com The script is: --- Cut --- #!/home/vladimir/php4/bin/php <% phpinfo () %> --- Cut --- You can see the result at http://book.ecompare-corp.com/cgi-bin/vxml/engines/kbb/phpinfo.php The first line of the page is #!/home/vladimir/php4/bin/php, and that's very annoying. I'm using PHP to generate XML output, and the XML parser that will read the output doesn't like the first line, and I can't blame it. --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=8506&edit=2

« previous php.dev (#48030) next »