PHP 4.0 Bug #9615: Cannot load libphp4.so into server
| From: | jr_evinger at hotmail dot com | Date: | Thu, 08 Mar 2001 08:15:12 +0000 |
| Subject: | PHP 4.0 Bug #9615: Cannot load libphp4.so into server | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-48213@lists.php.net to get a copy of this message | ||
From: jr_evinger@hotmail.com
Operating system: RedHat Linux 7.2
PHP version: 4.0.4pl1
PHP Bug Type: Apache related
Bug description: Cannot load libphp4.so into server
Using apache-1.3.19 with mysql and so module configured with no errors.
Configure;make;make install (ed) php with no errors using:
./configure --with-mysql=/usr/local/mysql-3.23.33-pc-linux-gnu-i686/
--with-apxs=/usr/local/apache_1.3.19/bin/apxs
On starting apachectl I get the following error:
"Syntax error on line 205 of /usr/local/apache_1.3.19/conf/httpd.conf:
Cannot load /usr/local/apache_1.3.19/libexeclibphp4.so into server: undefined symbol:
uncompress"
Line 205 of httpd.conf is simply the LoadModule line that reads:
"LoadModule php4_module libexec/libphp4.so"
I read that it was suggested on one bug report to add to the LIBS1 line in Makefile so mine now
reads:
"LIBS1= -lpthread -lm -lcrypt -ldl"
I performed: "make clean;make;make install: and the same error occurs.
I am just in the process of setting up this server. PHP was the third app installed. The first was
mysql and apache was the second. I did a custom install with the following components selected:
XWindows, GNOME, Mail-WWW-News Tools, DOS|Windows Connectivity, Graphics, Games, Multimedia,
Networked Workstation, Anonymous FTP server, Authoring/Publishing, Developement Tools, and
Utilities.
The machine is an 800MHz with 256 RAM. Plenty of partition space as well as swap space too.
Thanks for any help.
JR
--
Edit Bug report at: http://bugs.php.net/?id=9615&edit=1