PHP 4.0 Bug #9687: x-httpd-source fails with zero length
| From: | markhers at green-ant dot com | Date: | Sun, 11 Mar 2001 22:22:19 +0000 |
| Subject: | PHP 4.0 Bug #9687: x-httpd-source fails with zero length | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-48678@lists.php.net to get a copy of this message | ||
From: markhers@green-ant.com
Operating system: RedHat 7.0
PHP version: 4.0 Latest CVS (11/03/2001)
PHP Bug Type: PHP options/info functions
Bug description: x-httpd-source fails with zero length
For a while, I have been experiencing an irksome problem since about 4.0.4, but I can't
pinpoint when exactly it started.
On RedHat 7.0, I have the following webserver running:
Apache/1.3.19 (Unix) PHP/4.0.5-dev mod_ssl/2.8.1 OpenSSL/0.9.5a
on a 500 Mhz P3 with 240 MB of RAM.
The PHP DSO module is built from the CVS pull from about 12pm PDT today (3/11/2001).
Anyway, whenever I try to access a pretty colored source code version of any of my files via .phps
(where .phps is one of the extensions setup as an application/x-httpd-source type), I get a
"zero data" message from my browser.
The physical configruation line shows:
AddType application/x-httpd-php-source .phps .inc
I compiled PHP as a CGI version to see if it was an Apache issue, and the same thing happens.
The Apache child processes aren't dying, either. And the logs show a content legth of 0 and a
successful request, so i don't have any idea what's really going on.
I'm willing to assist anyone in determining the cause of the problem, but I haven't seen
it listed anywhere else.
I have the following PHP configuration:
'./configure' '--with-apxs=/opt/apache/sbin/apxs'
'--enable-track-vars' '--enable-inline-optimizations'
'--enable-trans-sid' '--with-mysql' '--with-pgsql=/usr/local/pgsql'
'--with-curl=/usr/local/curl' '--with-gd'
'--with-t1lib-dir=/usr/local/t1lib' '--with-ttf' '--enable-pcre'
'--with-bz2=/usr/local/bzip2' '--with-zlib' '--with-zlib-dir=/usr'
'--enable-wddx' '--with-dom=/usr/local/libxml'
Any help or pointers to provide more help is welcome.
--
Edit Bug report at: http://bugs.php.net/?id=9687&edit=1