Re: PHP 4.0 Bug #9493 Updated: compilation and make with ldap ok but problem during make with apache
| From: | Alain Defrance | Date: | Mon, 19 Mar 2001 08:34:01 +0000 |
| Subject: | Re: PHP 4.0 Bug #9493 Updated: compilation and make with ldap ok but problem during make with apache | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-49327@lists.php.net to get a copy of this message | ||
thanks for your reply...
all works fine now...
have a good day
ID: 9493 Updated by: sniper Reported By: alain.defrance@univ-evry.fr Old-Status: Open Status: Feedback Bug Type: LDAP related Assigned To: Comments: Where in your system are the libldap.a(or .so) and liblber.a(or so) located? Try adding that path into --with-ldap=/base/dir configure option. ie. --with-ldap=/www/openldap (if your libs are in /www/openldap/lib) --Jani Previous Comments: --------------------------------------------------------------------------- [2001-03-05 05:58:49] alain.defrance@univ-evry.fr helo, "Try setting the LD_LIBRARY_PATH before trying to start Apache: # export LD_LIBRARY_PATH=/path/to/openldap/lib/directory" i've done this but it's always the same... --------------------------------------------------------------------------- [2001-03-03 17:47:55] sniper@php.net Try setting the LD_LIBRARY_PATH before trying to start Apache: # export LD_LIBRARY_PATH=/path/to/openldap/lib/directory --Jani --------------------------------------------------------------------------- [2001-03-02 11:16:17] alain.defrance@univ-evry.fr i've tried to compil in module in DSO i've an another error : Syntax error on line 207 of /www/conf/httpd.conf: Cannot load /www/libexec/libphp4.so into server: ld.so.1: ./httpd: fatal: reloca tion error: file /www/libexec/libphp4.so: symbol ldap_unbind_s: referenced symbo l not found difficult no ??? --------------------------------------------------------------------------- [2001-03-02 10:31:17] alain.defrance@univ-evry.fr 3. Have you tried PHP 4.0.4pl1 if it works better? yes, now and i've the same error... some people said we must add --lldap to LDFLAGS, but where in makefile, on command, in php4 compilation, or in apache compilation ??? --------------------------------------------------------------------------- [2001-03-02 09:58:18] alain.defrance@univ-evry.fr 1. What was the configure line used to configure PHP 4? ./configure --with-apache=../apache_1.3.17 --with-ldap --enable-trach-vars configure :ok make :ok make install : ok 2. Which LDAP libraries are you using? Openldap 2.x.x? openldap-2.0.7 3. Have you tried PHP 4.0.4pl1 if it works better? not yet... thanks for your kind replies... --------------------------------------------------------------------------- The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online. ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=9493&edit=2******************************** Alain Defrance Service Informatique Université d'Evry Val d'Essonne A.Defrance@univ-evry.fr 01.69.47.80.69 www.univ-evry.fr ********************************