Re: PHP 4.0 Bug #9876: OCIPLogon flaky after restart Oracle
| From: | Thies C. Arntzen | Date: | Tue, 20 Mar 2001 18:27:46 +0000 |
| Subject: | Re: PHP 4.0 Bug #9876: OCIPLogon flaky after restart Oracle | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-49535@lists.php.net to get a copy of this message | ||
On Tue, Mar 20, 2001 at 04:55:31PM -0000, merrill@missioncriticallinux.com wrote:
> From: merrill@missioncriticallinux.com
> Operating system: Redhat 6.1 Linux
> PHP version: 4.0.4pl1
> PHP Bug Type: OCI8 related
> Bug description: OCIPLogon flaky after restart Oracle
>
> ./configure' '--prefix=/var/php' '--with-config-file-path=/var/php'
> '--enable-track-vars'
> '--enable-sigchild'
> '--with-apache=../apache_1.3.14' '--with-ftp' '--with-xml'
> '--with-mcrypt=/var/libmcrypt'
> '--with-pgsql=/var/postgresql'
> '--with-oci8=/u01/app/oracle/product/8.1.6'
> '--with-mysql=/var/mysql'
>
> When using OCIPLogon for persistent connections, I'm noticing that after restarting
> Oracle, that my PHP application starts getting Oracle errors(ORA-03113 and ORA-03114). This can be
> fixed by restarting the webserver after restarting Oracle. I also notice that changing my Oracle
> connections from OCIPLogon to OCILogon fixes the problem - after making that change I get no errors
> after restarting Oracle, and I *don't* have to restart the webserver.
>
> The OCI8 interface must have a bug, right? I shouldn't have to restart the webserver
> after restarting Oracle just because I'm using persistent connections, should I?
>
plz try the latest 4.0.5RC - we have made some changes - and
mayby your problem is solved with it. -but- my expierience is
(and i'm the author of the oci8 interface) that the oci libs
become unstable once you hard-closed some open connections.
you could also comment in some code in do_connect (search for
XXX and oci_ping) which checks if the connection is alive
_before_ returning it to the script.
tc