free() errors in PHP-4.0.5RC1

From: Date: Wed, 21 Mar 2001 18:21:36 +0000
Subject: free() errors in PHP-4.0.5RC1
Groups: php.dev 
Request: Send a blank email to php-dev+get-49647@lists.php.net to get a copy of this message
One of my OpenBSD servers hosed itself overnight, after the upgrade to PHP-4.0.5RC1. The problem was that the webserver suddenly segfaulted all of its children (saw this in the error log), and then dumped around 900MB worth of errors into the error log. This hurt my /var partition :-) The errors are: httpd in free(): warning: chunk is already free. httpd in free(): warning: chunk is already free. httpd in free(): warning: chunk is already free. httpd in free(): warning: chunk is already free. httpd in free(): warning: page is already free. httpd in free(): warning: chunk is already free. httpd in free(): warning: chunk is already free. httpd in free(): warning: chunk is already free. ... until /var fills up ... Now, this is a BSD warning, and I can turn it off by fiddling with /etc/malloc.conf, but the fact that it's showing up is a bit iffy. Anyone got any insight? Nothing like this happened using PHP-4.0.4pl1 or previous. More details will be forthcoming if I can reproduce the problem (it doesn't help that the Apache error logs seem to lack a timestamp). This is the server that runs demo.horde.org, so it primarily uses the IMAP module for remote, unstable connections. Anil

« previous php.dev (#49647) next »