PHP 4.0 Bug #7713 Updated: snmp functions not returning any data
| From: | j dot f dot howlett at bris dot ac dot uk | Date: | Mon, 02 Apr 2001 14:18:55 +0000 |
| Subject: | PHP 4.0 Bug #7713 Updated: snmp functions not returning any data | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-50589@lists.php.net to get a copy of this message | ||
ID: 7713
User Update by: j.f.howlett@bris.ac.uk
Status: Closed
Bug Type: SNMP related
Description: snmp functions not returning any data
Sorry, didn't get to you - this indeed fixed this (particular!) problem.
Thanks for your assistance.
Previous Comments:
---------------------------------------------------------------------------
[2001-01-12 10:34:41] sniper@php.net
No feedback --> closed. (considered problem solved)
--Jani
---------------------------------------------------------------------------
[2000-12-05 18:37:14] sniper@php.net
You haven't compiled snmp as shared extension for PHP.
Put a ; in front of the extension=snmp.so in php.ini.
Check that you have /usr/local/lib in /etc/ld.so.conf (if it isn't add it and run ldconfig).
Then try to start apache again.
--Jani
---------------------------------------------------------------------------
[2000-12-05 13:48:21] j.f.howlett@bris.ac.uk
Ooops, getting tired.....: libsnmp.so is in /usr/local/lib as you'd expect. Changed
extension_dir back to /usr/local/lib, but same problem:
"/usr/local/lib/snmp.so: cannot open shared object file: no such file or directory in Unknown
on line 0'.
---------------------------------------------------------------------------
[2000-12-05 13:38:20] j.f.howlett@bris.ac.uk
For some reason, php stopped compiling altogether --with-snmp. (perhaps due to attempting compile
with most recent version of ucd-snmp?). So......
Followed previous instructions, plus I recompiled ucd-snmp with --enable-shared
After this, php compiled fine with: --with-apxs --with-pgsql --with-snmp.
The extension_dir was not looking in the right place for snmp.so, so I set extension_dir in php.ini
to "/usr/share/snmp" (location of snmp.so).
However, on restarting Apache, error in /var/log/httpd/error.log:
PHP Warning: Unable to load dynamic library '/usr/share/snmp.so' -
/usr/share/snmp/snmp.so: cannot open shared object file: No such file or directory in Unknown on
line 0.
[Repeated again]
Thanks...
---------------------------------------------------------------------------
[2000-12-04 12:30:39] sniper@php.net
Where is the snmp.so located in your system?
Is the path of it in /etc/ld.so.conf ??
If not, add it and run ldconfig.
--Jani
---------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view the rest of the comments,
please view the bug report online.
Full Bug description available at: http://bugs.php.net/?id=7713