PHP 4.0 Bug #10125 Updated: installation fails - php doesn't run

From: Date: Mon, 02 Apr 2001 22:42:01 +0000
Subject: PHP 4.0 Bug #10125 Updated: installation fails - php doesn't run
Groups: php.dev 
Request: Send a blank email to php-dev+get-50640@lists.php.net to get a copy of this message
ID: 10125 Updated by: phildriscoll Reported By: ctek@ctek.ch Status: Closed Bug Type: IIS related Assigned To: Comments: The error is (surprise surprise) that MSCOMCTL.OCX which should be registered on your system, isn't. The installer program (and many many others) use this DLL to provide widgets like progress bars. It may be that the file exists on your system but is just not correctly registered. (The following is true for NT4 - things may be different on W2K) There should be a file called REGSVR32.EXE on your WinNT\System32 directory and also a file called MSCOMCTL.OCX in the same directory. If not, you will have to get them, maybe from your NT CD or perhaps by downloading them from somewhere on the Microsoft site. Once the files are there, from the command line type: REGSVR32 MSCOMCTL.OCX The installer should then work. A VB wizard somewhere in the world is modifying the installer to do this automatically so that the small percentage of users this affects will avoid the inconvenience. Previous Comments: --------------------------------------------------------------------------- [2001-04-02 17:37:14] jmoore@php.net Please contact phill driscoll, phildriscoll@php.net, directly. THis error is normally caused by mscomctl.ocx not being registered properly. Your second error is somthing unrelated to PHP but looks like some problem with northwind examples or somthing like that.. James --------------------------------------------------------------------------- [2001-04-02 17:33:10] ctek@ctek.ch i have a strange bug here, don't now where to search. when i install php with setup.exe on my win 2000 server, there is a error message: - component mscomctl.ocx or one of its dependencies not correctly registered, a file is missing or invalid after clicking on OK, php setup says OK, successfull installation. i check the isapi extension in IIS 5.0 --> nothing so, i did manual configuration every php-script is terminating with a http error 500 - internal server error in the system-event-protocol i have an error 10004: EventID 10004 Source DCOM DCOM got error "Logon failure: unknown user name or bad password. " and was unable to logon redmondcomstud in order to run the server: {5e9ddec7-5767-11cf-beab-00aa006c3606} or similar same happens with an installation of IHTML or other script-server dll.... who can help? --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=10125&edit=2

« previous php.dev (#50640) next »