PHP 4.0 Bug #10136: Function mail() does not work properly

From: Date: Tue, 03 Apr 2001 13:57:57 +0000
Subject: PHP 4.0 Bug #10136: Function mail() does not work properly
Groups: php.dev 
Request: Send a blank email to php-dev+get-50693@lists.php.net to get a copy of this message
From: arnaud@cenet.fr Operating system: Win32 (2K and 9x) - IIS 5 & Apache 1.3.19 PHP version: 4.0.4pl1 PHP Bug Type: Mail related Bug description: Function mail() does not work properly First, I tried making mail() function work() on a Win2k - IIS 5.0 server and on Win98SE - Apache 1.3.19 both with PHP 4.0.4pl1. there are several things wrong (so far it wouldn't be me the problem ;-) ) : - first : mail ("Arnaud <arnaud@cenet.fr>","A subject here","A message body here",...); (as mentioned in PHP manual), It won't work, i have a "Warning: Server error on blabla.php3:lineXX" but if the "To:" Field is replace by just an email adress : mail("arnaud@cenet.fr",....); this would work... So I can't send mails with the name of the recipients properly set (just their email adress)... NB: Multiple "To:" Recipients works but only with email adresses That's not the most important problem for me, the most important is Cc: and Bcc: won't work. The manual mentions to add From: Cc: and Bcc: information, in the fourth parameters (the headers)... So I tried : mail("arnaud@cenet.fr","A subject here","A (very nice !) body here","From: The Administrator <admin@cenet.fr>\nBcc: My Friend <myfriend@cenet.fr>\nCc: My Father <myfather@cenet.fr>"); it obviously doesn't work :-(( (that's why I'm writing you !!) There are several things to say : - The From: section of headers works well, nothing to say about it... No problem - Seems the Bcc: part is just ignored, nothing happen, no mail is sent to Bcc: address - For Cc:, when typed "cc:" (all lowercase) seems to be ignored but when typed "Cc:" => It looks like there is a memory leak or something like that both IIS and Apache return me a "emalloc() : unable to allocate -851230 bytes"... The number of unallocated bytes is not ever the same but this is the same error message... Extra info : - On both config, the mail server is a local mail server (FTGate 2.2.2.1) - It seems that this bug is similar to #9858 and #9859 in the bug database -- Edit Bug report at: http://bugs.php.net/?id=10136&edit=1

« previous php.dev (#50693) next »