PHP 4.0 Bug #10186: Apache cannot load libphp4.so symbol ap_block_alarms

From: Date: Thu, 05 Apr 2001 14:34:16 +0000
Subject: PHP 4.0 Bug #10186: Apache cannot load libphp4.so symbol ap_block_alarms
Groups: php.dev 
Request: Send a blank email to php-dev+get-50939@lists.php.net to get a copy of this message
From: helmut@ifit.uni-klu.ac.at Operating system: SunOS pisun7 5.6 Generic_105181-05 sun4u sparc SUNW,Ultra-2 PHP version: 4.0.4pl1 PHP Bug Type: Apache related Bug description: Apache cannot load libphp4.so symbol ap_block_alarms # ./apachectl start Syntax error on line 205 of /opt/apache/conf/httpd.conf: Cannot load /opt/apache/libexec/libphp4.so into server: ld.so.1: /opt/apache/bin/httpd: fatal: relocation error: file /opt/apache/libexec/libphp4.so: symbol ap_block_alarms: referenced symbol not found ./apachectl start: httpd could not be start # ldd httpd libpthread.so.1 => /usr/lib/libpthread.so.1 libsocket.so.1 => /usr/lib/libsocket.so.1 libnsl.so.1 => /usr/lib/libnsl.so.1 libc.so.1 => /usr/lib/libc.so.1 libdl.so.1 => /usr/lib/libdl.so.1 libmp.so.2 => /usr/lib/libmp.so.2 libthread.so.1 => /usr/lib/libthread.so.1 # ldd libphp4.so libpam.so.1 => /usr/lib/libpam.so.1 libdl.so.1 => /usr/lib/libdl.so.1 libresolv.so.2 => /usr/lib/libresolv.so.2 libm.so.1 => /usr/lib/libm.so.1 libsocket.so.1 => /usr/lib/libsocket.so.1 libc.so.1 => /usr/lib/libc.so.1 libnsl.so.1 => /usr/lib/libnsl.so.1 libmp.so.2 => /usr/lib/libmp.so.2 Server version: Apache/1.3.19 (Unix) compiled from source. -- Edit Bug report at: http://bugs.php.net/?id=10186&edit=1

« previous php.dev (#50939) next »