PHP 4.0 Bug #7790 Updated: can't start apache after compiling with --with-mcrypt

From: Date: Tue, 10 Apr 2001 16:56:28 +0000
Subject: PHP 4.0 Bug #7790 Updated: can't start apache after compiling with --with-mcrypt
Groups: php.dev 
Request: Send a blank email to php-dev+get-51375@lists.php.net to get a copy of this message
ID: 7790 Updated by: cmv Reported By: brainy79@yahoo.com Old-Status: Open Status: Closed Bug Type: mcrypt related Assigned To: cmv Comments: 1) You don't need the --disable-posix-threads switch for libmcrypt 2.4.x anymore. 2) Can you retry with the latest PHP CVS? Re-open this bug report if you are still experiencing problems. - Colin Previous Comments: --------------------------------------------------------------------------- [2000-11-13 14:28:17] brainy79@yahoo.com Libmcrypt 2.4.6 (configured with --prefix=/usr/local/libmcrypt --disable-posix-threads) compiled and installed with no problem. PHP is configured with ./configure --quiet --with-apxs=/usr/local/apache/bin/apxs --with-imap=/usr/local/src/imap/imap-4.7c --with-mcrypt=/usr/local/libmcrypt PHP compiles and installs with no errors. Upon starting apache (1.3.14+the latest mod_ssl), I get the following error: Syntax error on line 210 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: Unresolved symbol in /usr/local/lib/libmcrypt.so: lt_dlopen /usr/local/apache/bin/apachectl startssl: httpd could not be started Exit 3 Any ideas? -Eric --------------------------------------------------------------------------- ATTENTION! Do NOT reply to this email! To reply, use the web interface found at http://bugs.php.net/?id=7790&edit=2

« previous php.dev (#51375) next »